Informatie voor de Cisco 1605R aan ADSL inclusief configuratie.

Informatie :

De bedoeling van deze pagina is het aansluiten van de Cisco 1605R op het ADSL netwerk van KPN via in mijn geval XS4ALL.

Het is me uiteindelijk gelukt om de router aan de gang te krijgen met het ADSL ip address rechtstreeks op eth1 van de router.

Nu heb ik dus de situatie dat de Cisco voor mij de NAT translations maakt en ik moet zeggen dat werkt een stuk soepeler als de NAT entry's binnen de Alcatel.

Ook het aanmaken van port forwards t.b.v. een web of ftp server werkt een stuk simpeler (mits je bekend bent met het Cisco IOS).

Het image van het IOS dat ik op dit moment gebruik is : c1600-bk8nor2sy-mz.122-8.T4.bin, voor dit image heb je wel een 16Mb flash kaart nodig.

 

Technische informatie Router:

Cisco 1605R IOS versie: 12.2

Flash: 16Mb

Geheugen: 24Mb

Alcatel: Tweaked speedtouch home

De Configuratie:

De configuratie van de Cisco kun je op deze pagina downloaden.

Verder moeten er in je Alcatel nog een paar routes aangemaakt worden en moet je gebruik maken van de SIP_SPOOF handleiding zonder nat.

 

Cisco 1605R configuratie:

!
no service pad
service password-encryption
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname CISCO1605
!
logging buffered 4096 debugging
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default local
enable secret 5 PASSWD
!
!
!Users to login your cisco
username 1stuser password PASSWD
username 2nduser password PASSWD
username 3rduser password PASSWD
!
!
!
!
no service config
no ip finger
no service finger
no ip bootp server
no service udp-small-servers
no service tcp-small-servers
no cdp run
no snmp-server
no ip http server
no service dhcp
no ip source-route
!
ip nat translation tcp-timeout 3600
ip nat translation udp-timeout 3600
ip nat translation icmp-timeout 3600
!
!
!
!
!
!
!
interface Ethernet0
description Connected to LAN
ip address 192.168.1.xxx 255.255.255.0
ip nat inside
no ip directed-broadcast
arp timeout 360
no shutdown
!
interface Ethernet1
description Connected to ADSL modem
ip address 10.0.0.150 255.0.0.0 secondary
ip address 213.xxx.xxx.xxx 255.255.255.240
ip nat outside
no ip directed-broadcast
arp timeout 360
no shutdown
!
!
!
ip nat inside source list 111 interface Ethernet 1 overload
!
!Port forward for webserver
ip nat inside source static tcp 192.168.1.xxx 80 213.xxx.xxx.xxx 80 extendable
!
!End port forwards
!
ip route 0.0.0.0 0.0.0.0 10.0.0.138
ip route 10.0.0.138 255.255.255.255 Ethernet1
!
access-list 111 remark --- NAT list ---
access-list 111 deny ip any 10.0.0.0 0.255.255.255
access-list 111 permit ip 192.168.1.0 0.0.255.255 any
!
!
!
!
!
!
!
banner motd #
*************************************************************
Put some nice and shiney warning message between this lines. :-))
*************************************************************
#
!
!
!
!
ip domain-lookup
ip domain-name xs4all.nl
ip name-server 194.109.6.66
ip name-server 194.109.9.99
!
!
clock timezone gmt +01 00
!
line con 0
exec-timeout 0 0
password login
line vty 0 4
password login
transport input none
!
ntp server 194.109.6.65
!
end
!
!